Discussion:
LineInfo
Add Reply
Marco Borsari via fpc-devel
2017-04-03 08:25:38 UTC
Reply
Permalink
Raw Message
Does it is possible that the LineInfo trace (-gl option) are broken (no output)
in 3.0.2 version on Linux (at least)?
--
Marco Borsari <***@libero.it>
_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.freepascal.or
Michael Van Canneyt
2017-04-03 09:11:24 UTC
Reply
Permalink
Raw Message
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken (no output)
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/

Michael.
_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://l
Martok
2017-04-03 10:17:59 UTC
Reply
Permalink
Raw Message
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken (no output)
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/
AFAIR lineinfo.pp only works with Stabs? Didn't the default change to Dwarf?


Martok





_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.freepascal.org/cgi-bin/
Sven Barth via fpc-devel
2017-04-04 07:08:05 UTC
Reply
Permalink
Raw Message
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken (no output)
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/
AFAIR lineinfo.pp only works with Stabs? Didn't the default change to Dwarf?
AFAIK -gl automatically picks the correct one depending on the debug info
that's used for the main program. (At least that's what I assumed up until
now...)

Regards,
Sven
Michael Van Canneyt
2017-04-04 08:21:21 UTC
Reply
Permalink
Raw Message
Post by Marco Borsari via fpc-devel
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken
(no output)
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/
AFAIR lineinfo.pp only works with Stabs? Didn't the default change to
Dwarf?
AFAIK -gl automatically picks the correct one depending on the debug info
that's used for the main program. (At least that's what I assumed up until
now...)
That is so.
But I thought of this and tried with -gs and -gd (or whatever the DWARF option was)
I got the issue with both kinds.

Michael.
_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.freepascal.org/cgi-bin/mailman/listinfo/fpc-deve
Tomas Hajny
2017-04-04 08:41:23 UTC
Reply
Permalink
Raw Message
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken
(no output)
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/
AFAIR lineinfo.pp only works with Stabs? Didn't the default change to
Dwarf?
AFAIK -gl automatically picks the correct one depending on the debug info
that's used for the main program. (At least that's what I assumed up until
now...)
That is so.
But I thought of this and tried with -gs and -gd (or whatever the DWARF option was)
I got the issue with both kinds.
Is there any difference between the internal and external linker (-Xe)?

Tomas


_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.freepasc
Sven Barth via fpc-devel
2017-04-04 12:14:00 UTC
Reply
Permalink
Raw Message
Post by Tomas Hajny
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
Does it is possible that the LineInfo trace (-gl option) are broken
(no output)
Post by Martok
Post by Michael Van Canneyt
Post by Marco Borsari via fpc-devel
in 3.0.2 version on Linux (at least)?
Hm. Indeed. I can reproduce the issue :/
AFAIR lineinfo.pp only works with Stabs? Didn't the default change to
Dwarf?
AFAIK -gl automatically picks the correct one depending on the debug info
that's used for the main program. (At least that's what I assumed up until
now...)
That is so.
But I thought of this and tried with -gs and -gd (or whatever the DWARF option was)
I got the issue with both kinds.
Is there any difference between the internal and external linker (-Xe)?
Internal linker is not yet enabled on Linux.

Regards,
Sven

Loading...