Discussion:
CUPS support for FPC libs
(too old to reply)
Juha Manninen
2017-06-04 09:34:18 UTC
Permalink
Raw Message
Regarding issue:
https://bugs.freepascal.org/view.php?id=31245

Could cupsdyn.pp be moved to FPC packages?
In Lazarus printer4lazarus package it is wrongly tied to widgetset
instead of OS. It prevents using CUPS with QT widgetset for example.
FPC's OS dependent libs are logically the right place for such a unit.

Maybe FPC already supports CUPS somehow. I did not study the issue further.

Juha
_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.
Michael Van Canneyt
2017-06-04 10:07:18 UTC
Permalink
Raw Message
Post by Juha Manninen
https://bugs.freepascal.org/view.php?id=31245
Could cupsdyn.pp be moved to FPC packages?
Probably, yes.
Post by Juha Manninen
In Lazarus printer4lazarus package it is wrongly tied to widgetset
instead of OS. It prevents using CUPS with QT widgetset for example.
FPC's OS dependent libs are logically the right place for such a unit.
Maybe FPC already supports CUPS somehow. I did not study the issue further.
As far as I know, it does not. I don't see any evidence of it, but if you
create a ticket and assign it to me, I will add it.

Michael.
_______________________________________________
fpc-devel maillist - fpc-***@lists.freepascal.org
http://lists.freepascal.org/cgi-bi

Loading...